TeamCapri

Please login or register.

Login with username, password and session length
Advanced search  

News:

Summer will be upon us soon! Make sure you check the Meets subforum to see if there's a get-together near you!

Author Topic: Electrical issues? Maybe?  (Read 244 times)

Thomcapri96

  • Newbie
  • *
  • Posts: 1
    • 1993 mercury capri
Electrical issues? Maybe?
« on: April 08, 2020, 03:24:25 PM »

Hello! I'm having problems with my 1993 mercury capri, I did a spark plug change and replaced the old battery post terminals because the old ones were very worn and were starting to be a pain to take off. I did the spark plugs one at a time so that I wouldn't mess up the firing order so I dont think that's what's wrong but I did have to cut the old positive terminal off because it was integrated into the lead then I just stripped the plastic from the wire and put on the new terminal. When I hook the car back up to the battery the headlights immediately start flapping up and down out of sequence like they're waving at me the car doesn't start either turning the ignition does nothing. I've tried charging the battery and repositioning the wires Inside they're new terminals thinking maybe I shorted Something but I still have flappy headlights. Anyone know what I did wrong?  :-[
Logged

Rocketman

  • Administrator
  • Old-Timer
  • *****
  • Posts: 5210
    • 91 BPT AWD Capri & 1991 XR2
    • http://www.werbatfik.com
Re: Electrical issues? Maybe?
« Reply #1 on: April 08, 2020, 06:01:24 PM »

It sounds like you hooked the battery up backwards.
Logged
1.8L Turbo All Wheel Drive Capri... the "GTXR2"