TeamCapri

Please login or register.

Login with username, password and session length
Advanced search  

News:

New & potential members - due to overwhelming spam registrations, it's been very hard to sort through new registrations. If your account has not been approved, check your spam folder! If not please contact us at admin[AT]teamcapri.com and we'll sort it out for you.

Pages: 1 ... 8 9 [10]
 91 
 on: December 24, 2017, 11:36:47 AM 
Started by greywolf27030 - Last post by greywolf27030
Merry Christmas to all.

Jack Byrd

 92 
 on: December 22, 2017, 04:02:20 PM 
Started by greywolf27030 - Last post by greywolf27030
High idle problem was broken PCV valve.  When replacing the alternator, the mechanic broke the PCV and he just stuck it back together without the guts.  Now idle is back down where it should be, but after the car is warmed up, the hoses going to the IAC stay cool, ie. there's no flow thru the IAC.  Fast idle on cold start until you stop and it heat sinks.  Then when you crank it up, it idles at 900RPM, until you run down the road then it goes back up to 1750,  Haven't taken it apart to see why yet.  What is the easiest way to check the turbo end play?  I'm assuming there shouldn't be any appreciable play?

Jack Byrd

 93 
 on: December 22, 2017, 03:51:29 PM 
Started by mikeh - Last post by greywolf27030
Mine is white, Presently I have a red hardtop on it, very Christmasie.

Jack Byrd

 94 
 on: December 22, 2017, 01:26:38 AM 
Started by bicbic - Last post by Rocketman
Josh here had an issue years ago where the bearings inside his distributor were going out, causing the center shaft to rattle around and throw weird signals to the pickup. It caused a stutter at certain RPMs. He replaced the distributor with a used one and it ran fine.

Also, the turbo 323 guys had issues for a long time where the springs that hold the mechanical timing advance weights in the distributor would snap, the weights would sling out and run on the inside of the case and eventually cut thru the case like a pipe cutter. I've never heard of this issue on any XR2, I have a feeling Mazda knew about it and put better quality springs in our distributors. But our precious little cars are getting older.

I doubt these are common issues but it may be worth investigating

 95 
 on: December 21, 2017, 07:09:30 PM 
Started by bicbic - Last post by bicbic
Ok, we installed a new Ignition control Module and it fixed it about 90%  it still has a little hesitation, but wow did it make a difference in my pickup.  The only thing left to replace is the ECM/PCM.  Anybody else having this issue, let me know what you have done to fix the issue.  Thanks

 96 
 on: December 21, 2017, 01:34:55 PM 
Started by mikeh - Last post by WashiestSnake
Even if I pick up his I need a spare bumper, i plan on making a custom bumper or at the least try to replicate the Clubsprint style.

 97 
 on: December 21, 2017, 10:23:33 AM 
Started by mikeh - Last post by mikeh
Mine is closer Mike.  Why don't you put a belt on it and drive it?

Jack Byrd

I drive this one.



Oh that's true I forgot about that. My car is fixed too, next weekend would be the best time, preferably Sunday if you could.
So I take it you don't need mine...

 98 
 on: December 21, 2017, 09:23:04 AM 
Started by mikeh - Last post by WashiestSnake
Oh that's true I forgot about that. My car is fixed too, next weekend would be the best time, preferably Sunday if you could.

 99 
 on: December 20, 2017, 05:27:01 PM 
Started by mikeh - Last post by greywolf27030
Mine is closer Mike.  Why don't you put a belt on it and drive it?

Jack Byrd

 100 
 on: December 20, 2017, 02:19:06 PM 
Started by Twinthrill - Last post by Twinthrill
Thanks Rocket

Pages: 1 ... 8 9 [10]