TeamCapri

Please login or register.

Login with username, password and session length
Advanced search  

News:

If you've registered make sure emails from TeamCapri are not landing in your spam folder!

Author Topic: Fan always on  (Read 91 times)

Stickshifter6

  • Newbie
  • *
  • Posts: 21
    • 1993 Capri 5 Speed 1994 Capri 5 Speed
Fan always on
« on: May 27, 2018, 10:55:08 AM »

My radiator fan is always running. The only thing I can think of is I replaced the sensor with a used one from a parts car, could this be bad?

here's a picture of the sensor I replaced
http://shop.moderncapriparts.biz/Catalog/ProductDisplay.cfm?id=14613&cid=148
Logged

Gaz

  • Sr. Member
  • ****
  • Posts: 360
  • Do no harm, take no sh!t.
    • 92 XR2, 96 Outback, 77 KZ650
    • Saint Cloud Exhaust
Re: Fan always on
« Reply #1 on: May 27, 2018, 11:58:28 AM »

Usually, this is caused by a bad ground from the harness to the top of the thermostat ground that is transferred through the bolts securing the thermostat. Create another ground from the thermostat housing to the block or another ground and it should stop.
Logged

pilotlars

  • Newbie
  • *
  • Posts: 29
    • 1993 Mercury Capri
Re: Fan always on
« Reply #2 on: May 27, 2018, 02:34:49 PM »

My 1992 Mazda 323 had the same issue with the AC fan. The only way to shut it off was to remove the relay. it would run with the engine off and key removed. Since the car's AC didn't work anyways and I was going to spend 100s bringing it up to R132a spec I just went without it. That probably doesn't help you though.
Logged

Rocketman

  • Administrator
  • Old-Timer
  • *****
  • Posts: 5010
    • 91 BPT AWD Capri & 1991 XR2
    • http://www.werbatfik.com
Re: Fan always on
« Reply #3 on: May 27, 2018, 04:51:17 PM »

My 1992 Mazda 323 had the same issue with the AC fan. The only way to shut it off was to remove the relay. it would run with the engine off and key removed. Since the car's AC didn't work anyways and I was going to spend 100s bringing it up to R132a spec I just went without it. That probably doesn't help you though.

The sensor could be bad, the ground could be poor.
If you have removed the AC system and the AC harness, you will need to jumper the harness plug on the firewall for the fan to return to normal function
Logged
1.8L Turbo All Wheel Drive Capri... the "GTXR2"


Stickshifter6

  • Newbie
  • *
  • Posts: 21
    • 1993 Capri 5 Speed 1994 Capri 5 Speed
Re: Fan always on
« Reply #4 on: June 03, 2018, 11:08:56 PM »

I ordered a new temperature sensor and it fixed the issue! For anyone needing one of these, rockauto has them for $10. They are $30 and up everywhere else I looked.

It the Airtex Wells part #1t1120

https://www.rockauto.com/en/catalog/mercury,1993,capri,1.6l+l4,1196670,cooling+system,temperature+sender+/+sensor,4748
« Last Edit: June 03, 2018, 11:10:47 PM by Stickshifter6 »
Logged