TeamCapri

Please login or register.

Login with username, password and session length
Advanced search  

News:

Remember! TeamCapri is a donation driven site. There are no ads here!

Author Topic: 91 N/A With ?injector? issue??  (Read 734 times)

Int_Doggo

  • Newbie
  • *
  • Posts: 14
    • 91 Capri - 5 Speed
91 N/A With ?injector? issue??
« on: February 07, 2018, 04:15:56 PM »

So, My 91 N/A has a check engine light on that's been on for about 4 months...

The car runs perfectly fine aside from 2 things,

1. When in gear, and the engine is running from 1.1k-2.5k there is a ticking that sounds like an injector coming from the engine bay and is very noticeable from the inside of the car... oddly enough it doesn't speed up with the revs, just stays the same tempo... tick tick tick tick tick

2. *sometimes*, very occasionally the idle will drop to about 600 and run rough, as soon as I put on throttle it runs fine, but if I let it drop to idle, the idle stays at 600. after about 30 seconds to 1 minute the idle kicks back up to 900-1000 and runs fine.

I don't see/hear any vacuum leaks, and the previous owner (good friend of mine) says the check engine light is coming from the Cam Angle Sensor (also apparently it's the ICM, yet the part is listed online as a Cam Angle Sensor). Still doesn't explain that tick though...
Logged
~ My Capri ~
1991 Mercury Capri N/A
5 Speed Manual
White Soft top, No Hard top
Xr2 Spoiler added

Current Mileage: 246,436

Please message me if you can source a rebuild
kit that would work with the n/a engine.

SHOwn

  • Sr. Member
  • ****
  • Posts: 287
    • 91 XR2
Re: 91 N/A With ?injector? issue??
« Reply #1 on: February 07, 2018, 10:04:55 PM »

http://www.teamcapri.com/forum/index.php/topic,3504.msg127939.html#msg127939

Start searching the forum is all I can suggest. I completely forgot that there was a cam sensor. That's the best I can offer. Traffic has been pretty light here on TeamCapri lately, so it might take some time until someone with experience chimes in.
Hope that helps.
Logged
R. Powell
'91 XR2, LM 16" Chrome Drifters, White Gauge Faces, Kuhmo 40's, Big Brake UG, 2.5" Mandrel Bent CATback, BMW318 Heated Seats, `94 console, '99 Dodge Neon Spoiler, '94 XR2 Sideskirts Bumpers and taillights, Fresh Basecoat-Clearcoat Cardinal Red (Jul2014), vj11/vj14 hybrid, manual boost CTL.

jdp

  • Jr. Member
  • **
  • Posts: 77
    • 1994 Magenta Capri NA, 94 Reef greenXR2 and 92 XR2
Re: 91 N/A With ?injector? issue??
« Reply #2 on: February 07, 2018, 10:22:25 PM »

Have you tried pulling a code to see what is setting the check engine light?  I sure don't know what the tick would be if it does not speed up with revs.
Logged
John

SHOwn

  • Sr. Member
  • ****
  • Posts: 287
    • 91 XR2
Re: 91 N/A With ?injector? issue??
« Reply #3 on: February 08, 2018, 06:11:15 AM »

About the only thing I could dream up was cooling fan, (constant speed) but it would be high rpm. Now cabin fan could do it at low speed only maybe. Strange, the entire engine and drivetrain rotate at varying speeds.
Logged
R. Powell
'91 XR2, LM 16" Chrome Drifters, White Gauge Faces, Kuhmo 40's, Big Brake UG, 2.5" Mandrel Bent CATback, BMW318 Heated Seats, `94 console, '99 Dodge Neon Spoiler, '94 XR2 Sideskirts Bumpers and taillights, Fresh Basecoat-Clearcoat Cardinal Red (Jul2014), vj11/vj14 hybrid, manual boost CTL.

Int_Doggo

  • Newbie
  • *
  • Posts: 14
    • 91 Capri - 5 Speed
Re: 91 N/A With ?injector? issue??
« Reply #4 on: February 23, 2018, 08:52:08 PM »

Yeah, its one of the weirder things, since its always ticking at the same bpm.

Anyway, now she is starting to die immediately after startup.

Crank, 1k rpm, sputter, die.
All in about 1.5 seconds.

I ordered the new icm that should fix the CE light, but I'm getting worried...

I'm also buying an ebay engine and I've sourced a rebuild kit ;)

So there might be teardown/walkthrough of building a Mazda B6D.

Logged
~ My Capri ~
1991 Mercury Capri N/A
5 Speed Manual
White Soft top, No Hard top
Xr2 Spoiler added

Current Mileage: 246,436

Please message me if you can source a rebuild
kit that would work with the n/a engine.

SHOwn

  • Sr. Member
  • ****
  • Posts: 287
    • 91 XR2
Re: 91 N/A With ?injector? issue??
« Reply #5 on: February 23, 2018, 10:00:08 PM »

Just thought of something. How's the fuel pressure? I'm wondering if something like the regulator might be opening at regular intervals. Otherwise all I can attribute the regular ticking to would be either a relay or the cabin fan. Couldn't that ICM cause the dying also?
Logged
R. Powell
'91 XR2, LM 16" Chrome Drifters, White Gauge Faces, Kuhmo 40's, Big Brake UG, 2.5" Mandrel Bent CATback, BMW318 Heated Seats, `94 console, '99 Dodge Neon Spoiler, '94 XR2 Sideskirts Bumpers and taillights, Fresh Basecoat-Clearcoat Cardinal Red (Jul2014), vj11/vj14 hybrid, manual boost CTL.