TeamCapri

Please login or register.

Login with username, password and session length
Advanced search  

News:

New & potential members - due to overwhelming spam registrations, it's been very hard to sort through new registrations. If your account has not been approved, check your spam folder! If not please contact us at admin[AT]teamcapri.com and we'll sort it out for you.

Author Topic: TPS???  (Read 241 times)

WVFish

  • Newbie
  • *
  • Posts: 5
    • 93 Capri (just arrived)
TPS???
« on: August 17, 2017, 09:23:45 PM »

2nd post and the problems are mounting. 93 Capri 85,000 miles. 1st couple drives took gas well but was sluggish, filled with high test and added a can of "sea foam" by the bottom of that tank was really running well, then I cleaned under the hood, had a little residual water where it shouldn't be. Blew everything out and let it sit apart, open overnight to make sure it was good and dry, ever since then its got a miss, starting out just at low rpm now its all the time, pulled code and it was tps code. Well I just paid $189.00 for a used window regulator, and today the only tps I could find was $189.00 getting 189.00 to death. Help!!!! Thanks in advance
Logged

Pappy T

  • Jr. Member
  • **
  • Posts: 85
    • 91 base Capri
Re: TPS???
« Reply #1 on: August 18, 2017, 08:38:46 AM »

Hey WVFish,Did you dry out distributor real good ? Check cap n rotor too. Sounds like time to start pulling wiring connections and using electronic cleaner in them , put some di electric grease in them before reconnecting too. Good luck with it.
Logged

WVFish

  • Newbie
  • *
  • Posts: 5
    • 93 Capri (just arrived)
Re: TPS???
« Reply #2 on: August 18, 2017, 11:38:09 AM »

Thanks did that last eve again through the whole loop plug, plug wire, distributor. DTC code #12 tps fault. Don't mean to be a tight wad but  between a window regulator and TPS $400.00 starting to hurt. Just hoping someone had a line on the tps I'll be installing window reg. hopefully this eve.
Logged