TeamCapri

Please login or register.

Login with username, password and session length
Advanced search  

News:

Summer will be upon us soon! Make sure you check the Meets subforum to see if there's a get-together near you!

Pages: 1 2 [3]

Author Topic: 94 N/A idles great but feels like rev limit or limp mode on acceleration  (Read 3554 times)

Pappy T

  • Jr. Member
  • **
  • Posts: 99
    • 91 base Capri

Thanks for that one Terrymetal, I did notice my temp gauge isn't working since I got it out of mothballs ... maybe it's been going on the fritz and finally pooped out , we'll find out next week or two fingers crossed .  Thanks again !
Logged

terrymetal

  • Newbie
  • *
  • Posts: 8
    • 1992 Mercury Capri Convertible, 1979 Ford Ranchero

Its no problem!!  I hope everything works out for you! My car runs horrible right now and the throttle cable broke yesterday. Never ends with these cars!!  Terry
Logged

Pappy T

  • Jr. Member
  • **
  • Posts: 99
    • 91 base Capri

Well , cleaned my temp sending wire and sender , not too grody , and temp gauge works again ! BUT , still have the sputters  :(
 Anyone want to buy a nice Capri ?!
Logged

Rocketman

  • Administrator
  • Old-Timer
  • *****
  • Posts: 5112
    • 91 BPT AWD Capri & 1991 XR2
    • http://www.werbatfik.com

The temp sender is not read by the ECU. It has its own sensor on the bottom of the intake manifold
Logged
1.8L Turbo All Wheel Drive Capri... the "GTXR2"


Pappy T

  • Jr. Member
  • **
  • Posts: 99
    • 91 base Capri

Thanks Rocketman , I'll track that one down too !
Logged

Pappy T

  • Jr. Member
  • **
  • Posts: 99
    • 91 base Capri

Rocketman, did a little hunting around intake manifold , don't feel or see any kind of wiring . What should I be looking for ?  Thinking if I hadn't seen or noticed it before , could be my issue !? Thanks !
Logged

Rocketman

  • Administrator
  • Old-Timer
  • *****
  • Posts: 5112
    • 91 BPT AWD Capri & 1991 XR2
    • http://www.werbatfik.com



It's the sensor sticking out of the bottom of the intake manifold here.
Logged
1.8L Turbo All Wheel Drive Capri... the "GTXR2"


Pappy T

  • Jr. Member
  • **
  • Posts: 99
    • 91 base Capri

Holy cow . Looks like a lot of fun to get that one ,, don't remember messing with that one before even when I redid all the hoses , hope that does it.
Big Thank You  .
Logged

terrymetal

  • Newbie
  • *
  • Posts: 8
    • 1992 Mercury Capri Convertible, 1979 Ford Ranchero

They are a pain to get to and usually are corroded some and hard to turn out. If you have to replace it make sure the new one has thread sealer on it or put some on it. Makes it easier to install and less prone to leaks. Good luck! Terry
Logged

Pappy T

  • Jr. Member
  • **
  • Posts: 99
    • 91 base Capri

Wellll , got connector off and it was pretty clean , cleaned and reassembled it .. still doing it . A question I do have is with others in the same boat , does it sputter AFTER reaching temp or all the time , could rule out sensor ?   

Also , my brake light on the dash stays on , the blue wire that comes out the bottom of fluid reservoir  I found was disconnected , the ONLY plug I found was on firewall but it has 2 different color wires coming from it , plug from fluid is blue , any ideas here ??
  Thanks again guys .
Logged
Pages: 1 2 [3]