TeamCapri

Please login or register.

Login with username, password and session length
Advanced search  

News:

New & potential members - due to overwhelming spam registrations, it's been very hard to sort through new registrations. If your account has not been approved, check your spam folder! If not please contact us at admin[AT]teamcapri.com and we'll sort it out for you.

Author Topic: Trans issue  (Read 1095 times)

annie151

  • Jr. Member
  • **
  • Posts: 66
Trans issue
« on: March 17, 2008, 10:29:00 AM »

i have a 92 capri, manual.  I had just changed the trans seal because it was leaking.  When i accelerate it seems to hesitate before it kicks into gear.  Could some of the leaking fluid had sprayed on the clutch?  

The turbo sounds like its kicking into gear and the guages show so.  

also is gear fluid better than trans fluid?
Logged

1992xr2

  • Sr. Member
  • ****
  • Posts: 372
Trans issue
« Reply #1 on: March 17, 2008, 02:37:00 PM »

Always change your clutch after a rear main seal leak, I would suggest a SPEC lightweight pressure plate, a clutchnet 6-puck disc and a Fidanza fylwheel if you're baller and a LUK oem replacement if you're not.  I run Redline 70w140NS in my trasnny and really like it but it's ~$9/quart.
Logged
\\\'90 Civic Si
Flat black, built vtec d16. Low 14s
Boost in the near future.

Gus Kelley

  • Old-Timer
  • *****
  • Posts: 1089
Trans issue
« Reply #2 on: March 17, 2008, 04:36:00 PM »

Hey Annie! Get your gun!  Anyway, what did you mean by hesitate? Does the engine rev a little and then the car moves or does the engine spit and sputter then the car takes off?  Gus
Logged

annie151

  • Jr. Member
  • **
  • Posts: 66
Trans issue
« Reply #3 on: March 18, 2008, 02:57:00 AM »

thanks for the fast response.    My front driver's side boot ripped so i replaced the halfshaft.  It was the half shaft seal that was replaced.  

When i rev up the engine and then the car moves.  it does not sputter.
Logged